Descárgalo

Identificate

Nombre:

Contraseña:

Recordar



¿Recuperar la contraseña?

Regístrese

Usuarios revisando este tema :   1 Invitados:





SOLUCIONADO Re: actualización datos en hoja excel v5 y v4
Principiante
Registrado:
7/1/2016 17:30
Grupo:
Usuarios Registrados
Mensajes: 6
Nivel : 1
HP : 0 / 11
MP : 2 / 50
EXP : 47
Ausente
Gracias NJA, me has dado la luz con tu aportación, sólo por completar, tendríamos que hacer lo mismo con las demás columnas que también se han desplazado:
Anterior Auxiliar % Máx. Mín. Volumen Efectivo y Hora
Fecha no funcion.
Explicación:parece que el origen de los datos es: "infobolsa.es/mercado-nacional/mercado-continuo"
está página antes tenía 2 columnas más Ticker y Fecha, como ahora no están, el comando actualizar (hace un copiar pegar de esta web) y lo coloca en columnas diferentes, ya que el diseño de la Hoja no contempla este cambio.
Mientras no cambie el origen, seguirá funcionando, Y la fecha???? ¿ alguna idea?

P.D.
Tambien tendríamos que insertar celdas BI y BJ (sobre la linea 90) hasta alinear el número "1 con Abengoa" esto se debe a que la págian origen tiene ahora más líneas de publicidad.

Solución de NJA:
===============
Bueno, os cuento como lo he arreglado, espero que os funcione a vosotros.
Las pestañas cartera y operaciones (estoy con la v. 04 y excel 2013) toman los datos de cotizaciones del bloque amarillo primero de la pestaña "internet2". Este a su vez toma los datos del bloque rojo. Pues bien, en la columna CX (que corresponde al precio "último" en el bloque amarillo) os váis a la casilla correspondiente a Abengoa (en mi caso la fila 11), hacéis click y os aparece en el cuadro que se usa para definir lás fórmulas algo así:
=+SI($BJ98>0;BUSCAR($BJ98;$BJ:$BJ;BO:BO)), lo cual viene a decir que el valor precio "último" de CX lo tiene que buscar en la columna BO del bloque rojo. El problema es que, por algún motivo que desconozco, la columna BO ha desplazado su contenido a la columna BN y no basta con volver a desplazarla porque, como bien decíais, cuando se actualizan los datos se vuelve a mover. Así que lo que he hecho es sustituir la fórmula por esta otra:
=+SI($BJ98>0;BUSCAR($BJ98;$BJ:$BJ;BN:BN))

Ahora hay que hacer lo mismo con cada fila debajo de Abengoa pero eso se hace automáticamente haciendo click en la de Abengoa, y posicionando a continuación el cursor en la esquina inferior derecha hasta que os salga un signo +. En ese momento presionáis el botón izdo del ratón y, sin soltarlo, arrastráis hacia abajo el cursor a lo largo de la columna CX hasta que se acaben los títulos. Soltáis y ya estarán todas las casillas cambiadas buscando en la columna BN.
Como os decía, espero que se os solucione.

Enviado el: 10/3/2016 9:57
Transferir el mensaje a otras aplicaciones Transferir a


Re: SOLUCIONADO Re: actualización datos en hoja excel v5 y v4
Principiante
Registrado:
12/2/2012 14:24
Grupo:
Usuarios Registrados
Mensajes: 9
Nivel : 1
HP : 0 / 21
MP : 3 / 340
EXP : 86
Ausente
OK, solucionado, graciasssss !!!

Enviado el: 16/3/2016 2:18
Transferir el mensaje a otras aplicaciones Transferir a


Re: SOLUCIONADO Re: actualización datos en hoja excel v5 y v4
Aprendiz
Registrado:
2/1/2012 19:50
Grupo:
Usuarios Registrados
Mensajes: 17
Nivel : 2
HP : 0 / 46
MP : 5 / 745
EXP : 86
Ausente
Gracias por las indicaciones, creo que lo he arreglado.
Saludos.

Enviado el: 17/3/2016 16:44
Transferir el mensaje a otras aplicaciones Transferir a